Mise à jour le 11/07/2021

Depuis la sortie de Minecraft 1.17, l’utilisation de Java est un peu chamboulé par Mojang. Ils ne nous facilitent pas la vie !

Alors oui, si on utilise le launcher officiel, aucun soucis avec ça, car de lui-même il sait quelle version utiliser, mais MultiMC, oui et non ! M’enfin, il utilise la version que l’on lui donne 😂.

Donc aujourd’hui on va voir comment avoir une version 1.16.5 et 1.17 modé et fonctionnel 🙂 !

Les autres articles

Prérequis

Si vous lisez cette article avant le premier, ou si vous avez lu le premier avant le 11 Juillet, alors retournez le lire rapidement ! J’ai apporté des modifications à cette date !
Plus précisément, je veux que vous lisiez la partie sur Java et que vous installiez les deux version proposée ! Car si vous êtes ici, c’est que vous voulez jouer à une version 1.16.5 et 1.17.

Jouons à la 1.17 !

Version par défaut et erreur

Maintenant le vif du sujet !
Je pars du postulat que vous avez une instance 1.17 avec vos mods et que la version de Java par défaut dans MultiMC est la 1.8.0_291 (ou supérieur).

Version de Java par défaut

Ne la lancez pas tout de suite ! Vous allez avoir un gros message d’erreur d’un mod qui vous dira que Java n’est pas en version 16 ou supérieur !

Message d’erreur qui fait peur

Changer la version de l’instance

Pour corriger cela, rien de plus simple ! Bien évidemment, vous avez installé la version JDK 16 de Java (si, si, les prérequis). Donc on va modifier l’instance !

Mais pourquoi on ne change pas la version par défaut de MultiMC ?

Un lecteur avertis

Alors oui, c’est totalement possible ! Mais, dans ce cas, il faudra modifier toutes les autres instances 1.16.5 ou antérieur. La 1.17 vient de sortir, là je n’adapte qu’une instance. Si je change la version de Java par défaut, je dois changer x instances en 1.16.5, 1.15.2, etc. A vous d’adapter pour que ce soit le plus simple possible 😉.

Donc, revenons à nos moutons ! Faites un clique droit sur l’instance 1.17 puis Modifier l'instance. Vous l’avez aussi à droite.

Modifier l’instance

Allez dans Paramètres et vous verrez l’installation de Java. La case à cocher, ne l’est pas, car on utilise les paramètres par défaut, cocher là pour voir.

Version de Java de l’instance

Ca ne change rien ? Normal, vous avez juste activé le fait que cette option ne changera plus en fonction des paramètres globaux de l’application. On a désactivé l’héritage. Maintenant, cliquer sur Détecter automatiquement...

Détection !

Une nouvelle fenêtre s’ouvre avec les deux version de Java ! Sélectionner la bonne version pour cette instance. Dans notre cas la 16.0.1 et validez par OK.

Versions disponible

Le chemin d’accès change, ne vous en faites pas qu’il y ait écrit seulement javaw, vous pouvez cliquer sur Vérifier et vous devez obtenir un message de ce type.

Vérifier la version

Maintenant que c’est fait, cliquer sur Lancer pour voir 😉.

On croise les doigts… 🤞

Mais oui ça fonctionne, la preuve 😁

MC 1.17

Conclusion

Manipulations de plus à effectuer sur MultiMC, mais c’est intéressant de voir ceci, car en fait le Launcher officiel, fait exactement la même chose. Évidemment, dès le départ, je n’ai jamais dit que MultiMC était facile et pour un public débutant. Mais si vous êtes ici, c’est que vous aimez mettre les mains dans le cambouis comme moi 😁.

Et je terminerais là-dessus, avec la 1.18 qui arrive, faites bien attention quand vous suivez les actualités d’une nouvelle version de Minecraft, regardé quel version Mojang indique qu’il faut utiliser. Pour la 1.16.x ils l’avaient indiqué. Pour cette 1.17, ils l’ont indiqué aussi. Si vous surveillez ceci, vous ne serez jamais embêté.


2 commentaires

MultiMC | Dupliquer une instance et changer de version (2/5) | Gentlemen Of Craft · 11 juillet 2021 à 16h48

[…] MultiMC | Plusieurs versions de Java (6/6) (a venir) […]

MultiMC | Launcher alternatif qui vous veut du bien (1/5) | Gentlemen Of Craft · 11 juillet 2021 à 16h51

[…] MultiMC | Plusieurs versions de Java (6/6) […]

Laisser un commentaire

Avatar placeholder

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *