Dernière mise à jour le 22/03/2021

Dans cette article, je vais essayer de vous expliquer comment résoudre les erreurs des mods dans Minecraft. Je vais être transparent, je ne suis pas capable de résoudre toutes les erreurs, mais je tenterais ici de vous permettre de résoudre les plus simples.

Disclaimer : cette article est non exhaustive, mais avec le temps il devrait le devenir.

Erreur de version ou de dépendance manquante

Vous est-il déjà arrivé d’avoir ce message d’erreur au lancement du jeux ?

Erreur de version d’une dépendance

Décomposons cette erreur comme ceci

Décomposition erreur
  • Could not find required mod : En gros, le mod requis ne peut être trouvé. C’est le plus important du message. La première raison pourrait être que vous n’avez pas mis le mod du tout dans le dossier mods, commencer par vérifier cela.
  • lightoverlay requires cloth-config2 […] : Ici, l’erreur vous dit que vous avez le mod Light Overlay et que ce dernier souhaite le mods Cloth Config. Continuons la décomposition pour être plus précis.
  • cloth-config2 @ [>=4.10.13]} : Ici, la suite du message en vert, vous dit qu’il veut Cloth Config en version supérieur ou égale à (>=) 4.10.13

Avec toutes ces informations, deux solutions s’offrent à nous :

  • Nous n’avons pas Cloth Config dans le dossier mods
  • Nous avons une version antérieur à la 4.10.13

Allons faire un tour dans le dossier mods.

Liste des mods

On voit que j’ai bien le mods Cloth Config, il s’agit du fichier config-2-4.8.3. Bon, j’ai bien le mods, c’est pas ça le problème… Il me reste la version.

Version du mods

La grande majorité des mods (99,9 %) sont nommés avec leur numéro de version. Ici le mods est en version 4.8.3 et ils nous faut au minimum la version 4.10.13. Bingo !

Si on décompose, 4 et 4 sont égaux, on passe. 8 est inférieur à 10, donc le mods est dans une version inférieur à la 4.10.13 !

Et si nous avions le mods 4.10.5, ça passe ? Car on peut dire que c’est 4.10.50 ?

Un moddeur fou !

Et bien non ! En informatique, vous ne pouvez pas ajouter de zéro comme ça ! Si vous aviez eu cette version, les deux premiers (4 et 10) sont égaux, mais 5 est inférieur à 13. Oui, ça fonctionne comme ça l’informatique. Imaginez que le point sépare les numéros et qu’au lieu d’écrire 4.10.05, ben on simplifie par 4.10.5. Vous n’écrivez pas 00050 € dans la vrai vie ? Ben là c’est pareil 😋 !

Et si le mods n’est pas nommé avec son numéro de version ?

L’intello de la classe

Bien vu disait l’aveugle ! Pardon, bonne question ! Deux solutions dans ce cas.

Vous utilisez MultiMC, et lui vous indique la version du mods.

Version du mods dans MultiMC

Vous n’utilisez pas MultiMC, alors il faut ruser. Ouvrez le fichier du mods avec 7-Zip. Clique droit sur le fichier, puis 7-Zip et enfin Ouvrir archive

Ouvrir l’archive

L’archive ouverte, ouvrez le fichier fabric.mod.json. Pour cela double cliquer dessus. Si Windows vous demande avec quoi ouvrir le fichier, utiliser Bloc Notes. Pour ma part j’utilise VSCode de Microsoft.

Fichier à ouvrir

Et là, petite recherche, rapide ne vous en faites pas. Rechercher la ligne "version": "x.y.z",
Vous l’avez ? Ben vous avez aussi la version 😊

Version du mods

Voilà, on sait que le mods, ici Architectury est en version 1.10.137, et ça fonctionne pour tous les mods Fabrics !


0 commentaire

Laisser un commentaire

Avatar placeholder

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *